Skip to main content
  • GoDaddy Community
  • Building & Managing Client Sites
  • Building & Managing Client Sites

    cancel
    Showing results for 
    Show  only  | Search instead for 
    Did you mean: 
    Go to solution
    mewanyk
    New

    Website getting hung up

    Hey All,

     

    http://www.michaelewanyk.com/

    So I've recently built myself a site. However, I'm having some issues with the site loading. It seems to just get snagged and takes a long time. After it finally does load it's fine, but that's mainly due to caching and stuff. 

     

    But opening it in an incognito browser will show it will always hang and load a long time for a new viewer. I'm normally pretty good at finding bugs and fixing them, but I'm kind of at a loss here and hoping another set of eyes can give me a hand in finding the issue.

     

    Thanks!

     

    Mike

    1 ACCEPTED SOLUTION
    Muse
    Super User I

    @mewanyk 

     

    My go-to is to run a GTMetrix report.  I ran one on your site and there are a bunch of things to address.  Primarily properly sized images, layout shifts, and render-blocking resources: 

     

    https://gtmetrix.com/reports/www.michaelewanyk.com/X4UHbsv1/

     

    HTH! 😉

     

    Judith
    "Boldness be my friend." ~ William Shakespeare

    View solution in original post

    3 REPLIES 3
    Muse
    Super User I

    @mewanyk 

     

    My go-to is to run a GTMetrix report.  I ran one on your site and there are a bunch of things to address.  Primarily properly sized images, layout shifts, and render-blocking resources: 

     

    https://gtmetrix.com/reports/www.michaelewanyk.com/X4UHbsv1/

     

    HTH! 😉

     

    Judith
    "Boldness be my friend." ~ William Shakespeare

    View solution in original post

    Thanks for the help @Muse 

     

    So I did try to run it through something similar (and again through the site you suggested). I even tried getting rid of all the images as it is the majority of my load time and then rescanned to see if it would load faster. But from a cleared cache browser it still takes an eternity leading me to believe the cause is in the JS somewhere. Yet I'm not getting any errors in the debugger, so I'm just really confused. 

    @mewanyk 

     

    It could also just be the structure of the site is just not efficient.  Some themes are coded better and are faster than others...  

     

    I would address all the issues noted so that they are off the table.  You'll then see what is left and if they are addressable or not. 😉

     

      

    Judith
    "Boldness be my friend." ~ William Shakespeare