cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
New

PHP upgrading problem PHP 5.4 native to PHP 5.6

Hi,

I need to upgrade my PHP version to 5.6. But when I select PHP version from Cpanel I cant change PHP version . drop down option is being stacked . following message is showing :

" Warning: Changing php modules and php options via PHP Selector for native php version is impossible ".

 

It is not working when I press "switch to PHP version". Please help me to solve above mentioned problems.

Thanks

 

4 REPLIES 4
Highlighted
Moderator
Moderator

Re: PHP upgrading problem PHP 5.4 native to PHP 5.6

Hi @rezacw,

Welcome to our forums! PHP version 5.6 is not currently supported by any of our hosting plans. 

KayJay - GoDaddy | Community Moderator
24/7 support available at x.co/247support
New

Re: PHP upgrading problem PHP 5.4 native to PHP 5.6

If php version 5.6 is not supported by any of your hosting plans what do you do. I am using woocommerce with stripe which now requires and 5.6. Do I look for another host that does support.

Product Team
Product Team

Re: PHP upgrading problem PHP 5.4 native to PHP 5.6

@rezacw

Exciting news to all GoDaddy cPanel users. Your account is now updated with the latest PHP 7.0 and 7.1! If you want to update, login to your cPanel dashboard. Then under the Software heading click “Select PHP version”. In the top left of the PHP selection page use the dropdown the PHP version you want and click set as current. You are now ready to go! But a heads-up before you update, I recommend you check you site for compatibility first. If you have any questions our customer support team is happy to help 24/7. Just call (480) 505-8877.

 - Paul Seguritan, cPanel Product Manager

Re: PHP upgrading problem PHP 5.4 native to PHP 5.6

I changed my PHP version to 7.1 from  'select php version' under 'software' section. But it's not originally change and when I am going to run some command in root directory, It's saying to select choose php7.0 or later and showing php5.4 as current version. php5.4 is native in 'select php version'. How can I change the native php version?