• GoDaddy Community
  • Managed WordPress Hosting
  • Managed WordPress Hosting

    cancel
    Showing results for 
    Show  only  | Search instead for 
    Did you mean: 
    Go to solution

    Wordpress Managed PHP Version

    How to change PHP Version for GoDaddy Wordpress Managed it  need two be  update  because new woocommerce plugins recommend PHP Version two be 5.6. in  MySQL version need two be 5.6     wil this be  Automatic fix   in  MaxMind GeoIP Database: need fix  ps before i buy a new web hosting will this wordpress Managed be Automatic update two new PHP version 

    1 ACCEPTED SOLUTION
    Former Employee

    Hey folks, just wanted to let you know that PHP 7.2 is now available on all Managed WordPress sites.  You can change your PHP version in your Hosting dashboard.  Here are a couple screenshots:

     

    Screen Shot 2018-10-10 at 3.28.31 PM.pngScreen Shot 2018-10-10 at 3.28.46 PM.png

     

    Thanks,

    Gabe

     

    Gabriel A. Mays
    Head of WordPress, GoDaddy

    View solution in original post

    155 REPLIES 155
    Advocate III

    I'm curious what Godaddy's plans are for updating PHP for Managed WordPress Hosting.

     

    My sites currently report running under PHP version 5.4.42 which was released in June 2015. Version 7 should be significantly faster (see attached infographic snip from http://www.zend.com/en/resources/php7_infographic)

     

    Since version 7 landed in Dec 2015, I would think there would be ample opportunity for testing and validation for such an important component of WordPress hosting.

     

    What can we expect?

    WordPress Coach & Consultant

    Hi, thanks for reaching out and great question.

     

    PHP 7 delivers an awesome performance boost and has been fully compatible with WordPress since late last year.  Though, unfortunately many plugins and themes aren't fully compatible with it.  This is why you'll notice that no Managed WordPress host (that I know of) has fully rolled it out to all customers--it's a non-trivial thing.

     

    You're correct that our Managed WordPress Hosting is running on PHP 5.4.  This is because our current object caching layer only supports up to PHP version 5.4.  We have hardware on order to upgrade our caching layer to Redis in every datacenter, which will then allow us to upgrade to PHP 5.6 and a few other nice enhancements.

     

    So, what about PHP 7, right?  After we make to above upgrades later this year and launch our Asian datacenter we'll turn our focus to a larger, more substantial upgrade of our Managed WordPress platform which will include PHP 7 and a lot of other significant improvements.

     

    Sorry I can't give an exact date, but hopefully that context gives you a better idea of what we're up to and what to expect down the road.

     

    If you have any other questions just ask!

     

    Thanks,

    Gabe

    Gabriel A. Mays
    Head of WordPress, GoDaddy

    I vote also for PHP 7 on Shared Hosting here in GoDaddy. Other competitor like SiteGround have introduced this function many weeks ago and obviously it's an optional choice using the PHP Version manager. So please try to give us an eta for this upgrade.

     

    Thanks.

    Hi eveeybody, do you grave any news about Php7 to share with us? As I said before it's time to bring the new version of Php to shared hosting (version 7.0.9 can be considered a quite stable and mature).

    In a private conversation via tweeter with GD tech support they told me in June that will be a "great update including Php7 later this year".

    Someone could give us updates about this platform upgrade?

    Hey @emsoft,

     

    Afraid I don't have any specifics regarding a release date for PHP 7 on our shared hosting plans, but I do know it is something our engineers and administrators are looking to make available in future updates to our services. Right now, there just hasn't been any officially announced plans. 

     

    Once there's been an announcement, I'm sure there'll be more information we can provide. 

     

    CG - GoDaddy | Community Moderator
    24/7 support available at x.co/247support

    Hello @Gabe and @CG,

    I was curious if there was any more updates on this. The last update was almost 2 months ago, with the same information from almost 5 months ago. PHP 7.0 is almost halfway though it's active support. I have used GoDaddy hosting for almost 6 years now. Your support has always been amazing, but this is kinda taking for ever. 

    Yesterday I started looking into alternative share hosting plans with other companies that support PHP7. I would switch over to a VPS but I can't justify that price (359.88$ for the first year and then 479.88 every year after that) for less then a handful of websites just to support PHP7.

    I am still looking, but I am really hoping their is update news on this front, because I have always loved GoDaddy and would hate to have to leave over something as small as shared hosting not supporting PHP 7.

    Lastly, I don't even understand the excuse that not all plugins support PHP7, if someone decides to use a PHP version they should be smart enough to know they are opting into a version of PHP that not all the plugins are going to work.

    @mouse0270 Good question.

     

    We're on the tail end of upgrading our caching tier to Redis.  We're working hard to finish the Redis upgrade roll out, PHP 5.6 upgrade and MySQL 5.6 upgrade by the end of next month.

     

    I agree with you on PHP7.  However, the transition for hosts has been much harder than anticipated, which is why even the high priced premium Managed WordPress hosts haven't fully migrated yet.

     

    I don't have a timeline for PHP7 yet, but I can tell you that we're already working on it.  I agree with you, once we upgrade to PHP7 it'll be the default for new sites, with the option to switch back to PHP 5.6 if there are compatibility issues.  For existing/migrated sites we'd love to scan for PHP7 compatibility then upgrade them if compatible, with the option to remain on PHP 5.6 if there are compatibility issues.

     

    Thanks for the patience on this @mouse0270.  We are working on it and we want this as much as you do.  As WordPress enthusiasts, we'd love to have been on PHP7 a year ago, but with a platform with millions of active customer sites we have to be careful not to break things since customers are trusting us with their business.  I apologize we're not moving faster, but I promise you we're working on it.

     

    If you'd like to try PHP 7 sooner you could always try our Cloud product.  It's unmanaged like VPS and advanced, but supports PHP7 and has a 30-day free trial to try it out.

     

    Thanks for checking in @mouse0270, I appreciate your feedback.

     

    Gabe

     

    Gabriel A. Mays
    Head of WordPress, GoDaddy
    Former Employee

    Hi @emsoft please see my update above, sorry for not tagging you!

     

    Gabe

     

    Gabriel A. Mays
    Head of WordPress, GoDaddy

    Hello @Gabe I left out some details, because this was the only PHP7 forum I saw that appeared to have gotten any attention.

    So if you don't mind, I would like to ask for one further clarification, so I can make the best decision possible for my business. I actually didn't even know you had Managed WordPress Hosting, as I am on you Web Hosting. 

    Does the Web Hosting Package full under the same development as the Managed WordPress Hosting, or should I be looking into creating my own forum question get specifics related to Web Hosting PHP7 support?

    @mouse0270  Web Hosting is a separate product and should be getting PHP7 as an option sooner because it's an unmanaged platform, thus has much more flexibility.

     

    I don't know the timeline on that product, but they are working on it.  I believe once they upgrade from EasyApache 3 to 4 it should be pretty straightforward to make PHP7 available.

     

    Gabe

     

    Gabriel A. Mays
    Head of WordPress, GoDaddy

    Dear GoDaddy,

    What's the status on the upgrade to PHP 5.6? The below post was over 6 months ago and still no sign of it...

    I have plugins that are starting to require it.

     

    Thanks,

    Cam

    Bump on this.  I have a client locked into a ten year contract, and in addition to other problems with your cache layer (stripping out of UTM tags categorically), I understand that 5.4.45 may be one and a half years old, but PHP 5.5 series has been available since at least 2013.  There are many important use cases for supporting at least 5.5, 5.6 or ideally 7 ( best case would to have a user select their own version ).  Many other Managed Wordpress hosting environments support very important and increasingly standardized things such as PSR compliance on several levels (autoload especially) and many modern Wordpress frameworks lean heavily on Composer.  This is an opportunity to take GoDaddy from a relatively decent DNS provider to a reputable hosting provider as well.

    I updated my wordpress site with a new website builder plugin and it's saying my system isn't compatible and to contact the webhost.

    Here's the message I got...

    Your PHP version is not compatible.Please contact your webhost tech support and have them upgrade your server to use a faster, safer, and more modern version of PHP. Tell them you need to be running at least on PHP version 5.3.6, but 5.4, 5.5, and 5.6 are even better, because each newer version gets faster and more secure.

     

    How can I fix this??

    Thank you!

     

    Hello @ashields and @DNunez. The PHP upgrade is in progress and should be wrapped up shortly after the holiday break.

     

    Thanks,

    Gabe

     

    Gabriel A. Mays
    Head of WordPress, GoDaddy

    I've been reading all the posts re: php upgrade. I just updated the Publish to Apple News plugin, hoping that the fix was in, but still get the message: 
    Parse error: syntax error, unexpected T_STRING in /home/content/39/7725539/html/grannytravels/wp-content/plugins/publish-to-apple-news/apple-news.php on line 44

     

    WHEN is this going to be fixed? I am seriously contemplating moving my sites to a different host that doesn't have this issue.

     

    Thx

    Somewhere in this thread I saw that an announcement would be made towards the end of the first quarter. That has past. 

     

    Is PHP 7 coming or do I need to direct my clients elsewhere?

    My Managed WordPress account is now on PHP 5.6.27. PHP 5.6 rolled out on Managed WordPress a little while ago. It may continue to be rolling out now, Gabe Mays may have some more info.

     

    If you're on shared hosting you can select which PHP version you are using:

     

    https://ca.godaddy.com/help/view-or-change-your-php-version-3937

     

    Here are the current versions of PHP (and other parts of the stack) on GoDaddy:

     

    https://ca.godaddy.com/help/software-versions-shared-hosting-897

     

    I note cPanel, Plesk and Managed WordPress all support 5.6+ whereas the others do not.



    Alex Sirota, PMP - NewPath Consulting - Schedule some time with Alex
    "At the moment of commitment, the universe conspires to assist you." -Johann Wolfgang von Goethe
    Moderator

    Hi @joeelectronics.

    The PHP/MySQL version on Managed WordPress cannot be manually changed. The version is managed by our hosting teams. Our teams to apply updates as versions are tested and as needed by WordPress.

    ^Gary

    Gary - GoDaddy | Community Moderator
    24/7 Support | Check System Status

    When can we expect to get an update for the PHP version??

    i have the same issue i need to update to 5.6 i have plugins not working for woocommerce.