cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Go to solution

Domain Name Not working without www in blogger

Hey, this is actually a fix to domain redirection issue. I faced this problem, but managed to solve it with a simple trick. I thought maybe it can help many others who haven't received exact answer from Support team.

 

Fix Godaddy domain not working without non-www in blogger[Solved] Godaddy Domain not working without www Blogger.jpg

5 ACCEPTED SOLUTIONS
Super User III

This is a common issue, though I'll note the third section of the article isn't actually needed.  It creates yourdomain.com.yourdomain.com which I guess doesn't hurt anything, but it doesn't really help either.

 

If the host allows pointing to an IP address and handles the redirect on their end that would be the better option (which Google does in this situation, covered in the first 2 sections of the article).  In other situations where the host does not provide an IP address you may need to use domain forwarding, instead of sub-domain forwarding.

View solution in original post

I tried implementing Domain forwarding earlier, but I got following error on address resolve. Maybe I need to add SSL Certificate, again I'm in blogger and Google handles that, right?

 

ERR_TLS_CERT_ALTNAME_INVALID

 

PS: The page is loading fine with domain forwarding also.

View solution in original post

*** A Quick update:

 

I got "err_tls_cert_altname_invalid Error" because when I used domain forwarding the A records for "www" were removed. I added them back and bang all errors gone !! I'll update the article too.

 

Thanks for the support !!

 

View solution in original post

 

I ran the domain thru an SSL checker that tests each IP address individually, the top one is the forwarding server.

 

twistblog_sslcheck.PNG

 

So removing forwarding should solve the issue, as it does not use SSL.

 

It is possible there may have previously been some issue with the DNS records for Google, that could have been fixed when they were deleted and you added them again.

View solution in original post

Thanks Nate. I removed Domain forwarding and still the page without www (https://twistblogg.com) is loading successfully. Maybe it was problem from server side (Google) and as you mentioned removing and adding A records might have fixed the error. Thanks a lot, I learnt a lot of new stuffs and thanks again for providing your time. Can you confirm once if everything is fine?

 

I'll update the article once confirmation is done !

 

https://www.twistblogg.com/2019/09/solved-godaddy-domain-non-working-without-www.html

View solution in original post

13 REPLIES 13
Super User III

This is a common issue, though I'll note the third section of the article isn't actually needed.  It creates yourdomain.com.yourdomain.com which I guess doesn't hurt anything, but it doesn't really help either.

 

If the host allows pointing to an IP address and handles the redirect on their end that would be the better option (which Google does in this situation, covered in the first 2 sections of the article).  In other situations where the host does not provide an IP address you may need to use domain forwarding, instead of sub-domain forwarding.

View solution in original post

I tried implementing Domain forwarding earlier, but I got following error on address resolve. Maybe I need to add SSL Certificate, again I'm in blogger and Google handles that, right?

 

ERR_TLS_CERT_ALTNAME_INVALID

 

PS: The page is loading fine with domain forwarding also.

View solution in original post

*** A Quick update:

 

I got "err_tls_cert_altname_invalid Error" because when I used domain forwarding the A records for "www" were removed. I added them back and bang all errors gone !! I'll update the article too.

 

Thanks for the support !!

 

View solution in original post

@TwistBloggcomTo be clear you do not need forwarding at all if the host provides IP addresses to point the domain.  That is an alternate method for working with a host that does not provide the IP address, both methods should not be used at once as the settings conflict.

When I do not use Domain Forwarding, there was an issue -- the naked domain with https (https://twistblogg.com) was showing Certificate error. It never happened with me before with other domains. Its not me alone, there are many bloggers out there facing it.

@TwistBloggcom  Forwarding does not use SSL, so if someone tries to access a forwarded domain using https:// the browser would block it.

 

If you have multiple records for the same address one would be selected randomly each time, so some of your visitors would get one of the Google IP addresses and others would get the GoDaddy forwarding server.  If you are getting a valid SSL it is likely using one of the Google IP addresses, there's about 1/5 chance of getting forwarding instead...

 

twistblog_ff.PNG

 

twistblog_chrome.PNG

 

 

I will say it takes some time for these changes to take effect (usually an hour or two, but can take up to 48 hours).  It's really not uncommon for someone to do all the steps right, get worried and try a bunch of random other stuff, then when the right settings kick in become convinced it was from one of the random other things.

OK ! I got the probability thing, but my domain was connected to Blogger a month ago and there was no fix till today (except forwarding option), so now my question is: what should I do? What is the fix to this issue? What steps should I follow?

 

 

I ran the domain thru an SSL checker that tests each IP address individually, the top one is the forwarding server.

 

twistblog_sslcheck.PNG

 

So removing forwarding should solve the issue, as it does not use SSL.

 

It is possible there may have previously been some issue with the DNS records for Google, that could have been fixed when they were deleted and you added them again.

View solution in original post

OK, I'll let you know.

Thanks Nate. I removed Domain forwarding and still the page without www (https://twistblogg.com) is loading successfully. Maybe it was problem from server side (Google) and as you mentioned removing and adding A records might have fixed the error. Thanks a lot, I learnt a lot of new stuffs and thanks again for providing your time. Can you confirm once if everything is fine?

 

I'll update the article once confirmation is done !

 

https://www.twistblogg.com/2019/09/solved-godaddy-domain-non-working-without-www.html

View solution in original post

Yep, looks to be working good now.

Hi @Nate, I have followed the steps that are explained in this post, as per your advice, I have not applied the domain forwarding in GoDaddy to let it done by google.

 

But still my site is not working for this address : https://morgantechspace.com/

@KevinMorganIt looks to be working now for me.  Changes to the DNS usually take about an hour or two, but can take up to 48 hours.