cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Go to solution

Domain connected to, but not mapping, to a Google Sites site

I have set up a Google Sites site. I've set up a "Custom URL" for a name I've registered here at Godaddy.  Google Sites has verified the name as mine.  I also went to Google Search Console and retrieved the A record it wanted me to add to my DNS and I've added it. Console has verified it. All that is good to go.

 

But, when I go to my domain name, while it does send me to the Google Site site I've created--it is not mapping the domain. It is showing the sites.google.com... address in URL in the address bar, rather than my domain name.  This happens with me entering either www.mydomain.com or mydomain.com.

 

How do I get it to map my domain? Thanks!

 

Here are my settings:

 

Screen Shot 2020-04-11 at 12.41.13 PM.png

 

2 ACCEPTED SOLUTIONS

@slofleming 

 

Ok something is really odd than.... I would try to add in the forwarding - in this you should put in www.yourdomain.com (putting in your actual domain) as that is where it should be forwarding to

I am a GoDaddy End User - Just Like You
Check out my site! | I currently manage over 300 WordPress Websites
* Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

Once your issue is resolved,
please be sure to come back and click accept for the solution

Get Better Support on the Community Boards!
Etiquette When Asking for Help from the Community

View solution in original post

@slofleming 

1) Without Masking 

2) The reason for doing the forwarding is to all yourdomain.com to display the google site as otherwise only www.yourdomain.com will load

I am a GoDaddy End User - Just Like You
Check out my site! | I currently manage over 300 WordPress Websites
* Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

Once your issue is resolved,
please be sure to come back and click accept for the solution

Get Better Support on the Community Boards!
Etiquette When Asking for Help from the Community

View solution in original post

20 REPLIES 20
Super User IV

@slofleming 

 

This is a setting within Google to use your custom domain vs the the sites.

 

Here are some instructions from Google https://support.google.com/sites/answer/9068867?hl=en

I am a GoDaddy End User - Just Like You
Check out my site! | I currently manage over 300 WordPress Websites
* Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

Once your issue is resolved,
please be sure to come back and click accept for the solution

Get Better Support on the Community Boards!
Etiquette When Asking for Help from the Community

Thanks.  I had read that before. I just reread it, and I have done all that it said.

@slofleming 

 

In that case you will need to reach out to Google support as the mapping issue is on their side

I am a GoDaddy End User - Just Like You
Check out my site! | I currently manage over 300 WordPress Websites
* Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

Once your issue is resolved,
please be sure to come back and click accept for the solution

Get Better Support on the Community Boards!
Etiquette When Asking for Help from the Community

Steegle, who has written the article everyone follows for doing the mapping, told me on Google Discussions that it just needs to propagate fully.  However..

 

On my Macbook, it is mapping properly on both a Chrome window where I am signed into Google and also in an Incognito window.  But on the same device, Safari will not show anything, Private or signed in to Google, it gives me a "internal error - server connection terminated" error.
 
On the same wifi network, Chrome on my iMac shows the site, but the domain is not mapped--both logged in and in Incognito.  Same thing on my wife's imac.
 
And I've cleared caches.
 
So, why would it work on one computer and not another in the same network?  And why in Chrome and not in Safari on the same mac?  Can propagation cause this behavior?

@slofleming 

 

That sounds like something with your local network / computers - if the domain is updated it Google's system it should work in all the browsers 

I am a GoDaddy End User - Just Like You
Check out my site! | I currently manage over 300 WordPress Websites
* Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

Once your issue is resolved,
please be sure to come back and click accept for the solution

Get Better Support on the Community Boards!
Etiquette When Asking for Help from the Community

I just tested the potential home network issue.  I tried it on my iphone, with Wifi off, so it goes through my Verizon wireless internet rather than my Spectrum cable internet.  With Wifi turned off, it gives me a "internal error - server connection terminated" error.  When wifi is turned back on, I get a Godaddy parked page.

 

So it's not the network.  

 

It is strange why one way gives me a parked page and the other gives me an error.

@slofleming 

 

What is your domain so I can see the DNS from here?

I am a GoDaddy End User - Just Like You
Check out my site! | I currently manage over 300 WordPress Websites
* Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

Once your issue is resolved,
please be sure to come back and click accept for the solution

Get Better Support on the Community Boards!
Etiquette When Asking for Help from the Community

I pm'd site URL to you.

@slofleming 

Thank you for send the domain - When did you enable the forwarding of the domain??

 

When I did a lookup it was bouncing between the Parked IP and the Forwarding IP - So YES that would cause the delay if you had just updated it - 

 

odd that it would bounce back and forth on the same device, but it could be switching between DNS servers at your local (network) level and updated on one but not the other.

 

If you changed the forwarding more than an hour ago, I would get in contact with GoDaddy and ask them to do a Zone Refresh - this will resubmit the domain information to the servers.

 

The domain is set to a 10 Minute TTL - meaning that domain servers should check for updated

I just used https://manytools.org/network/query-dns-records-online/go/ to check your domain on the 2 servers it is assigned to (ns01 & ns02) and it is still reporting the Parked Page

 

The solution maybe the zone refresh as mentioned above.

 

I am a GoDaddy End User - Just Like You
Check out my site! | I currently manage over 300 WordPress Websites
* Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

Once your issue is resolved,
please be sure to come back and click accept for the solution

Get Better Support on the Community Boards!
Etiquette When Asking for Help from the Community

Thank you for checking out my domain.  I changed the DNS records on Saturday. Probably about 40 hours ago.

 

I can call Godaddy later today and ask for a Zone Refresh.

 

Generally speaking, if I call Godaddy for tech support on something like this, will I get an expert right away or will I have to go through being handed up the ladder of levels of expertise until I get someone that knows what they are doing?

@slofleming 

 

This is something that the general support folks should be able to accomplish. I would be specific with them that you have updated your domain from being on the GoDaddy Parked page to a forwarding address.

 

Your issue is that it keeps flipping back and forth The fact that is has been a few days says it isn't a propagation issue. 

 

Hopefully they shouldn't push back at you.

I am a GoDaddy End User - Just Like You
Check out my site! | I currently manage over 300 WordPress Websites
* Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

Once your issue is resolved,
please be sure to come back and click accept for the solution

Get Better Support on the Community Boards!
Etiquette When Asking for Help from the Community

I was just looking at my DNS record.  There is an A record with a value of "Parked." Is that necessary, what does that do?

@slofleming

Since you are using forwarding that should say forwarded which the godaddy system should automatically put in there. One option is to delete the forwarding and re add it
I am a GoDaddy End User - Just Like You
Check out my site! | I currently manage over 300 WordPress Websites
* Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

Once your issue is resolved,
please be sure to come back and click accept for the solution

Get Better Support on the Community Boards!
Etiquette When Asking for Help from the Community

"Since you are using forwarding that should say forwarded which the godaddy system should automatically put in there. One option is to delete the forwarding and re add it"

 

So, in the Value field where it says "Parked", what do I put in it when when I delete and add it back?

@slofleming 

 

You shouldn't have to touch that field - in the lower right corner of the DNS management page, I am assuming based on what I was seeing that you have Forwarding configured there. 

 

What I was saying was to delete that forwarding - give it a few minutes to refresh  - there should be a pencil next to the @ record (parked)...

 

Now go back and re-add your forwarding.... this should now change Parked to Forwarded

I am a GoDaddy End User - Just Like You
Check out my site! | I currently manage over 300 WordPress Websites
* Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

Once your issue is resolved,
please be sure to come back and click accept for the solution

Get Better Support on the Community Boards!
Etiquette When Asking for Help from the Community

In the bottom right of the page, where it allows me to Add Forwarding, it says, "Not Set Up."

@slofleming 

 

Ok something is really odd than.... I would try to add in the forwarding - in this you should put in www.yourdomain.com (putting in your actual domain) as that is where it should be forwarding to

I am a GoDaddy End User - Just Like You
Check out my site! | I currently manage over 300 WordPress Websites
* Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

Once your issue is resolved,
please be sure to come back and click accept for the solution

Get Better Support on the Community Boards!
Etiquette When Asking for Help from the Community

View solution in original post

With Masking or without?

 

FYI: None of the instructions for doing this for Google Sites says to set up forwarding.  But it's worth a try.  In case you're interested, this is the instructions everyone points to for making this work with Google Sites:  https://www.steegle.com/google-sites/how-to/assign-custom-url-domain-personal

@slofleming 

1) Without Masking 

2) The reason for doing the forwarding is to all yourdomain.com to display the google site as otherwise only www.yourdomain.com will load

I am a GoDaddy End User - Just Like You
Check out my site! | I currently manage over 300 WordPress Websites
* Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

Once your issue is resolved,
please be sure to come back and click accept for the solution

Get Better Support on the Community Boards!
Etiquette When Asking for Help from the Community

View solution in original post

It's working!  I tried on multiple browsers and on both my cable connection and my Verizon wireless connection. It's so interesting (confusing) to me that in no articles about how to set this up with Google Sites, does it say to add forwarding. In fact, I've seen Google Support Discussions saying to remove the forwarding.  

 

Regardless, it's working.  And I very much appreciate your hanging in there with me in this thread.  Thanks so much.