cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Exclude one page from https in managed wordpress with SSL

I have insecure iframed content on one page of my website running https in a managed wordpress account. How can I make one page http? The content provider does not provide https at this time.

Thnak you!

2 REPLIES 2
Super User I Super User I
Super User I

Re: Exclude one page from https in managed wordpress with SSL

Hello @BethPerkins,

 

I'm assuming that you are using some sort of method to force HTTPS otherwise the fully qualified domain would just show? If you are using a method through your .htaccess file then depending on the configuration it may be difficult. There is a way to make only specific pages HTTPS but it is time consuming to name every page so people usually will just use * or ^ and force everything using a rewrite rule. You can add exceptions in your .htaccess file though. It would look something like 

RewriteCond %{REQUEST_URI} !/your-page #add your excluded page here

inside of your .htaccess file.

 

What you should really look into doing is getting rid of the iframe. The iframe is probably more trouble than it is worth? I hope that at least gets you started?

...turns out that my two cents is worth less or more depending on the current exchange rate.

roy darling *my posts seem a lot shorter in my head

Re: Exclude one page from https in managed wordpress with SSL

I need to exclude one page from https in my managed WordPress website with SSL from GoDaddy just as this topic describs. The page is http://fakedomain.com/page-1/snow

I edited my .htaccess using:

RewriteCond %{REQUEST_URI} !/your-page     #I added my specific page here

It did not work, so I contacted GoDaddy support for help. They told me this is not possible with Managed WordPress accounts, but I do not believe this to be true. I've tried clearing local cache and GoDaddy cache, I've tried multiple browsers... all to no avail. Page still loads over HTTPS and the resulting HTTP content is consequently blocked. What am I doing wrong? GoDaddy tech support can't seem to help me or doesn't believe this is possible with Managed WordPress websites. My full .htaccess file looks similar to this:

 

# BEGIN GD-SSL
<IfModule mod_rewrite.c>
Options +FollowSymLinks
RewriteEngine On
RewriteCond %{HTTPS} !=on

RewriteCond %{REQUEST_URI} !/page-1/snow
RewriteCond %{HTTP_USER_AGENT} ^(.+)$
RewriteCond %{SERVER_NAME} ^fakedomain\.com$
RewriteRule .* https://%{SERVER_NAME}%{REQUEST_URI} [R=301,L]
Header add Strict-Transport-Security "max-age=300"
</IfModule>
# END GD-SSL

 

Please help!