Showing results for 
Show  only  | Search instead for 
Did you mean: 
Go to solution

Caller ID not showing from SmartLine

When a call comes in from my SmartLine account, it isn’t showing as coming in via SmartLine. It always has the number and says home underneath.

I am using on a iPhone X and have tried the following;

- Logging out and back in
- Deleting app and reinstalling
- Restarting phone
- Checking all settings
- Allowing contacts and notifications

It worked normally for a few days when I first downloaded it but now won’t work completely. I do get the notification just before the call but if I don’t have my phone in my hands I don’t see the notification.

I use my phone for business, my full time job, another part time job, and personal. I need to verify which calls are coming in through SmartLine so I know which way to answer my phone.
Does anyone have any ideas on how to get past this?
Product Team
Product Team

Re: Caller ID not showing from SmartLine

Hello @Taxitc


Thanks for reaching out to us!


Try the following:


1. Go to your iPhone Contact List

2. Find the contact "SmartLine Call"

3. Tap on Edit

4. You'll see your SmartLine #, tap on "home"

5. Then add a Custom Label called "via Smartline" or select it if it's already there.


When you allow the Contacts permission for our app, we attempt to set the custom label "via SmartLine".  But there are some scenarios where we can't such as if your contacts is synced from Google, Exchange, etc.  So you'll have to manually set it.


Let us know if that works for you





Re: Caller ID not showing from SmartLine



After some playing around and deleting the SmartLine contacts, deleting the app and redownloading again. And also changing the label It seems to be working now. I'm not sure what would have changed from when I first downloaded it until it stopped working. I appreciate the solution! 


Re: Caller ID not showing from SmartLine

I am having the same issue with an Iphone X.  When I go into my contact list I have 2 entries that say Smarline.  The first just says Smartline and then has a phone number that I don't recognize (maybe this is the phone number that Smartline uses internally?)  The second Smartline number says "Smartline Call" and has my office number that I have ported to Smartline for the home number.  Trying to follow your instructions, I do not see anywhere to create a Custom Label called 'via Smartline'.  I was able to delete both Smartline numbers via Outlook then I deleted the Smartline app and reinstalled it.  When it does the first test call it says "I see you are calling from xxx.  Where xxx is the number that I have ported to Smartline.  Shouldn't it say "I see you are calling from yyy, where yyy is my cell phone number which is what I'm really using at that moment?  Anyway, I DO get my calls when people call my ported landline.  The phone says GoDaddy Smartline but does NOT have the correct caller ID on the call.


Re: Caller ID not showing from SmartLine

Hi @MarkG,

To create the custom label "via SmartLine":

1. Go to your native contacts stored on your iPhone. 

2. Search for the "SmartLine Call" contact (this is your SmartLine number) and click Edit

3. Click on the name to the left of the phone number (this is most likely named 'home')

4. This will open a list of available name options (e.g., home, work, iPhone, mobile) 

5. Scroll towards the bottom of the list and find "Add Custom Label"

6. Type "via SmartLine"

7. Click Done. 


During the Test Call we are showing you the caller ID the recipients will see when you call them. To keep your personal number private, we display your SmartLine phone number (instead of your personal number). 


Thanks for reaching out.