cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Go to solution

Issue with contact form, possibly issue with PHP memory?

Hi community, hopefully, somebody can help.

I am working on a website for a client www.urbanedge.com and whilst I am working on this, we have released an under construction page with a contact form that visitors can fill out. However, this form does not seem to work. I got in contact with the theme creators for support and they gave the following reply: (Since the reply from the support I have changed the domain from a temp one to the main domain, hence the difference in domains.

 

MESSAGE FROM THEME SUPPORT: 

I can see when I run a message through the form that an error shows on the console:

POST http://61b.9fe.myftpupload.com/wp-content/plugins/engage-core/shortcodes/lib/contact-form/process.ph... 500 (Internal Server Error) contact-form.js?ver=4.9.4:93

The error you are receiving here is a '500 internal server error'. You will need to consult your hosting for the best course of action here -whether it may be to increase the memory or check the permissions for the js file.

(http://61b.9fe.myftpupload.com/wp-content/plugins/engage-core/shortcodes/lib/contact-form/public/js/...)


Can somebody explain this to me, I have no idea what I am doing or what the issue is. Feel free to check out the issue yourself at www.urbanedge.com try fill out the contact form and see for yourself how absolutely nothing happens when you press send. No errors, no confirmations, no actual mail sent.


Kind Regards,

Deivid

1 REPLY 1
Rockstar I Rockstar I
Rockstar I
Solution

Re: Issue with contact form, possibly issue with PHP memory?

Hi @DeividCole,

 

What platform are you using for hosting?  It does sound like you will need to increase memory.  If you are on a managed wp platform you will need to upload a .user.ini file that has some parameters for increased resources.   The contents would look something like:

 

memory_limit = 4096M
max_execution_time = 320
max_input_time = 240
post_max_size = 120M
max_input_vars = 2000
file_uploads = 6
max_file_uploads = 20
upload_max_filesize = 100M

 

You will need to create and upload this file via sFTP.

 

If you are on cPanel, you can scroll to the Software section, click on PHP version and then follow the dialogues to change the resource settings.  I'm pretty sure the link for that is on the top right after you enter the PHP version settings.

 

If you need a bit more help let us know!

James

 

 

 

Not Just Pretty Sites, Pretty Doggone Smart Sites