cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

PHP Error on web page

When I go to one of my pages - I see an error 

 

A PHP Error was encountered

Severity: Warning

Message: mysqli::real_connect(): Headers and client library minor version mismatch. Headers:50519 Library:50633

Filename: mysqli/mysqli_driver.php 

Can you help me resolving it? 

 

I am go-daddy managed hosting!

6 REPLIES 6
Helper V
Helper V

Re: PHP Error on web page

Since it's a Godaddy Managed Hosting you'll need to contact Godaddy to resolve the issue.

Please give it a +1 and also click "Mark As Accepted Solution" if you find it satisfactory. Thanking You With Regards | Harry Parmar

Re: PHP Error on web page

Thanks harry. 

Contacting go-daddy now, however,  just wanted to check  why this error would come !  FYI, no changes were done in last 4-5 months from our side in our code (as this is already a live  php app.)

 

thank you.

Helper V
Helper V

Re: PHP Error on web page

In today's world everything updates daily. So it's important keep an eye on your coding.

Please give it a +1 and also click "Mark As Accepted Solution" if you find it satisfactory. Thanking You With Regards | Harry Parmar

Re: PHP Error on web page

I have the exact same problem on my web site and a trouble ticket logged with tech support. The issue is that mysql was updated to version 5.6 and the php/wordpress page call out does not seem to line up with that version and hence the error message. On my wordpress pages I was using the plugin insert php to front and close my php code and tech support initially thought it was a plugin issue. I switched the plugin to easy replacement since wordpress does not recognize ?>php and ?> to bookend/sandwich php code in a page. The same warning 50519 error occurred so I believe it is not a plugin issue
I cannot even launch this simple script without the warning appearing on the results page
https://ca.godaddy.com/help/connecting-to-mysql-using-php-216

Leemer

Opencart 2.1 mysql_connect headers problem

I install opencart in 2016/10 with Applications function, it is no any problem, but few days ago , I got a warning message.

 

Warning: mysqli::mysqli(): Headers and client library minor version mismatch. Headers:50549 Library:50633 in /home/XXX/public_html/XXX.com/system/library/db/mysqli.php on line 7

 

and I can't login backend anymore, it only a blank page with the warning message. How can I fix the question??

 

It is the lastest version in Applications.

Re: PHP Error on web page

Hey, 

 

Steven here from OpenCart, If you could get in touch with us directly at OpenCart, we'll be happy to assist and get this looked in to and assist. 🙂

 

Support@opencart.com