cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Go to solution

Uploading WordPress themes and PHP Limit. How to increase?

Hi,

 

I've just started working on my website and I was trying to upload the Avada WordPress Theme and I got an error that says:

 

The uploaded file exceeds the upload_max_filesize directive in php.ini.

 

I have no idea what this means and how exactly to increase my limit. Now I have googled this and there are too many things out there that are far too technical for me to understand. If you have any simple suggestions on how to do this, that would be great.

 

Thanks in advance for all your help!

 

 

1 ACCEPTED SOLUTION
Advocate I

Create a text file on your PC and paste this in it:

 

memory_limit = 128M

upload_max_filesize = 100M

post_max_size = 128M

 

If you are using cPanel, name the file php.ini.  If you're using one of the older Classic Hosting Linux servers, call the file php5.ini.

 

Upload the file to the root directory of your hosting plan.  For cPanel, that would be public_html.  For the older servers, it's just the main / folder.

 

Give it a couple of hours since it has to wait for the server to do a soft reset after you make changes.  If you have cPanel, go to the PHP processes area and kill the processes.  After that will will recognize the new php.ini file immediately. Otherwise, like I said, wait a couple of hours.

View solution in original post

48 REPLIES 48
Advocate I

Create a text file on your PC and paste this in it:

 

memory_limit = 128M

upload_max_filesize = 100M

post_max_size = 128M

 

If you are using cPanel, name the file php.ini.  If you're using one of the older Classic Hosting Linux servers, call the file php5.ini.

 

Upload the file to the root directory of your hosting plan.  For cPanel, that would be public_html.  For the older servers, it's just the main / folder.

 

Give it a couple of hours since it has to wait for the server to do a soft reset after you make changes.  If you have cPanel, go to the PHP processes area and kill the processes.  After that will will recognize the new php.ini file immediately. Otherwise, like I said, wait a couple of hours.

View solution in original post

Does this override server .ini?

~Jan Mykhail Hasselbring Web Administrator @ fullstackwebsolution.com

That worked!!! Thank you so much!

On CPanel with Linux.  I understand from the documentation that I can use php.ini or user.ini.  I've tried both, but still get 413 error "The requested resource
/barcode/html/BCGean13.php
does not allow request data with GET requests, or the amount of data provided in the request exceeds the capacity limit"

 

I've stopped the processes and restarted them too, but still get the error.  Any ideas?

Community Manager

Hi @wotiso

 

I see that you posted this issue as part of a new thread, so I will respond there.

https://www.godaddy.com/community/Building-and-Managing-a-Website/PHP-limits-not-working-in-CPanel-w...

 

JesseW - GoDaddy | Community Manager | 24/7 support available at x.co/247support | Remember to choose a solution and give kudos.

I also need to do this but I have a managed wordpress site. Do I even have a cpanel? I don't think so. So can I do this with ftp? Thanks so much in advance.

If you've got your own self hosted wordpress site, you can try this:

https://wordpress.org/support/topic/how-to-increase-file-size-for-media-upload

I'm still waiting to hear if I can do this with a managed wordpress site. Do I need to do this with ftp? Thanks so much in advance.

When I tried overriding the master php.ini with a php.ini or user.ini file, it failed. Killing processes did not work. Tech support, after a lot of pondering, helped me to find this solution:

Log in to Web Hosting > cPanel

Go to software and select "Select PHP version" to arrive at a page that list the PHP extensions

In the upper right corner, select "Switch to PHP options"

Here you can change most of the settings that users want to change.

 

Thanks... This was the fix for me, using shared hosting.

This worked and was the easiest solution. I suggest anyone else having this problem tries this first.

In case anybody else stumbles across this thread the wording you look for is:-

 

upload_max_filesize

 

Then increase that one. Worked for me. I set it to 16mb using the div them from Elegant themes

FrankA Thank you for the guide. 

Thank you so much!

Frank A...."Brilliant"!!! 

Thank you!!

 

best solution ever

Thank you,

That worked for me.

 

This worked like a charm for me wohoo, thanks heaps 🙂

This is the fix that instantly worked! Thanks! 🙂

Brilliant, thank you!