cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Go to solution

Wordpress Address/Site URL greyed out

I would like to alter these URLs but they are greyed out in Settings...I have removed the "define" code from wp-config but that did not make a difference. Also checked functions.php and they are not set there. Any ideas on where else I should look or what I should change?

 

Thanks for any help!

1 ACCEPTED SOLUTION


@sdramsey wrote:

Thanks for your reply, Justin! I have already disabled all the plugins to no avail, and as I mentioned, removed the "define" code from wp-config. No change. 😞


@sdramsey this is really the only solution I can find to the problem. https://wpengine.com/support/trouble-editing-home-and-site-url/

 

How are you accessing your wp-config file? Are you going straight through FTP?

View solution in original post

7 REPLIES 7
Rockstar II


@sdramsey wrote:

I would like to alter these URLs but they are greyed out in Settings...I have removed the "define" code from wp-config but that did not make a difference. Also checked functions.php and they are not set there. Any ideas on where else I should look or what I should change?

 

Thanks for any help!


@sdramsey it could be several things. Which plugins are you currently using? Try disabling all of your plugins and then checking to see if the problem persists, this is usually the cause.

 

Another issue could be these two statements in your wp-config files:

 

define('WP_SITEURL', and/or define('WP_HOME', 

 

If they are, you can remove them and it should fix the problem. Please ensure that you have backed up a copy of your config file before making any modifications. 

 

---

Thanks for your reply, Justin! I have already disabled all the plugins to no avail, and as I mentioned, removed the "define" code from wp-config. No change. 😞


@sdramsey wrote:

Thanks for your reply, Justin! I have already disabled all the plugins to no avail, and as I mentioned, removed the "define" code from wp-config. No change. 😞


@sdramsey ok, does your website currently resolve?

I now think it must be something on the hosting end. If you go to http://sfcanada.org/, it does not resolve (although weirdly, it did yesterday, albeit with a messed-up front page). If you go to http://northbynotwest.com/SFCanada-WP/ , which is the hosting path, it resolves as normal. Until the day before yesterday it loaded just fine from sfcanada.org, and I made no changes (other than a blog page post), so that's what stumped me.

 

 


@sdramsey wrote:

I now think it must be something on the hosting end. If you go to http://sfcanada.org/, it does not resolve (although weirdly, it did yesterday, albeit with a messed-up front page). If you go to http://northbynotwest.com/SFCanada-WP/ , which is the hosting path, it resolves as normal. Until the day before yesterday it loaded just fine from sfcanada.org, and I made no changes (other than a blog page post), so that's what stumped me.

 

 


@sdramsey Both sites are currently resolving for me with no messages

 

--

Yes, the site is resolving now; that was an IP change issue. I still have the greyed out URLs, though. I guess I'll just give up that issue for now. I'd like to have all the page URLs show the sfcanada.org domain name but can't seem to get that to happen.


@sdramsey wrote:

Thanks for your reply, Justin! I have already disabled all the plugins to no avail, and as I mentioned, removed the "define" code from wp-config. No change. 😞


@sdramsey this is really the only solution I can find to the problem. https://wpengine.com/support/trouble-editing-home-and-site-url/

 

How are you accessing your wp-config file? Are you going straight through FTP?

View solution in original post