Showing results for 
Show  only  | Search instead for 
Did you mean: 

i have hosting with url. after setting up wordpress the www is missing from my url in the browser?

Helper III

usually the Top Level Domain is irrelevant toward the compatibility of a properly configured wordpress; however, i have come across some lazy developers that call mis-configurations a feature. You have 3 options:

  • change all the occurrences in your database to have www in the TLD.
  • change the site domain in wp-admin->settings
  • add a permanent redirect in your .htaccess file


RewriteEngine on
RewriteCond %{HTTP_HOST} ^ [NC]
RewriteRule ^(.*)$$1 [L,R=301,NC]


please note that, i offer direct support that is in no way associated with GoDaddy's regular support channels; but, for immediate technical support you can contact me at: