Yaaaaaas! This worked... I'm using Stout, a child theme of Primer. All you have to do is UNCHECK that "Display theme author credits" box! Appearance, Customize, Site Identity. Uncheck that box and that author credit goes away in the footer. So simple.